PERGUNTAS E RESPOSTAS
 
Bem Vindo, Visitante  Todos os Fórums
  SPEDs
Enviar para a impressoraImprimir  Enviar e-mail para um amigoEnviar Para um Amigo
Precisa estar Logado

Subject Assunto:
TRANSMISSAO NFE XML
Versão:
12.1.25
Plataforma:
Linux
Complemento:
Estacões Acessam via Windows
DB:
Oracle
Complemento:
LinkedIn
Foto
Mensagem do Enviar e-mail Abrir o Perfil do usuário KALL KALL em 15/01/2020, 07:06 h
Local: SP  Registro: 19/12/2008  Postagens: 13
Bom dia, Pessoal.

Estou com problemas na transmissão do XML, debugando o envio, verifiquei que na montagem da string, a função convert quando verifica o campo D2_FRETE retorna o valor para para a formação da TAG. Percebi que quando o valor fica menor que 1.00 de 0,99 para baixo, no retorno vi no debug que está trazendo mas não acrescenta a string vFrete com o valor em centavos causando a rejeicao de somatorio 610.

Problema parecido ocorre com a impressão do DANFE, todas as NFE´s, quando impressa, o sistema traz valores inteiros sem os centavos.

Alguém pode me ajudar?

Foto
Mensagem do Enviar e-mail Abrir o Perfil do usuário KALL KALL em 17/01/2020, 12:37 h
Local: SP  Registro: 19/12/2008  Postagens: 13
O problema era um framework expedido recentemente pela totvs, depois de atualizado, voltou a funcionar normalmente.

Para postar no Fórum você precisa efetuar o seu login ou se registrar

 Mudar para Fórum

 

 

 
 
   
Pagina Principal Shopping PROTHEUS Tire suas duvidas Vagas Microsiga em todo Brasil Aprofunde seus conhecimentos Noticias Online Fale Conosco Pagina Principal