PERGUNTAS E RESPOSTAS
 
Bem Vindo, Visitante  Todos os Fórums
  ADVPL
Enviar para a impressoraImprimir  Enviar e-mail para um amigoEnviar Para um Amigo
Precisa estar Logado

Subject Assunto:
DEmora para finalizar a primeira venda
Versão:
12
Plataforma:
Microsoft
Complemento:
DB:
SQL Server
Complemento:
LinkedIn
Foto
Mensagem do Enviar e-mail Abrir o Perfil do usuário FTACI FTACI em 12/03/2019, 08:24 h
Local: AL  Registro: 30/08/2005  Postagens: 99
Todos os dias quando fechamos a primeira nota, na finalização da primeira nota, o sistema demora em torno de 40 minutos para finalizar um pedido de venda, para os demais pedidos não há demora.


Não estou conseguindo achar o problema !

SEmpre na primeira venda. Depois volta ao normal.

Foto
Mensagem do Enviar e-mail Abrir o Perfil do usuário ALVESSGU ALVESSGU em 12/03/2019, 11:28 h
Local: SP  Registro: 23/10/2013  Postagens: 3
Será que o horário não coincide com algum processo que esta executando?

Foto
Mensagem do Enviar e-mail Abrir o Perfil do usuário FTACI FTACI em 12/03/2019, 11:33 h
Local: AL  Registro: 30/08/2005  Postagens: 99
Eu faço diretamente no servidor. Já verifiquei o horário, está de acordo com o horário de verão.

mesmo assim continuar com o problema ...

Foto
Mensagem do Enviar e-mail Abrir o Perfil do usuário SB_COELHO SB_COELHO em 12/03/2019, 12:43 h
Local: PB  Registro: 16/06/2014  Postagens: 54
Boa tarde FTACI, o que ALVESSGU perguntou foi se nesse horario não esta fazendo algo do tipo um backup ou outra rotina rotina rodando em segundo plano.

Supondo que a primeira venda seja pela manhã, no período da noite você esta parando os serviços do banco e/ou dbacess? se sim faça o teste de não parar, o sistema pode esta reindexando as tabelas e dependendo do tamanho do seu banco isso pode demorar bastante.

Se você tiver alguma customização, tente fazer o procedimento sem elas, no seu caso tem que analisar tudo que possa direta ou indiretamente influenciar nisso, pois pode ater demorar um pouco a primeira vez que roda uma rotina, mas não os 40min que você falou.

Atenciosamente,
Silvio Coelho.

Foto
Mensagem do Enviar e-mail Abrir o Perfil do usuário EXCELCPD EXCELCPD em 13/03/2019, 08:48 h
Local: MG  Registro: 19/10/2009  Postagens: 50
Bom dia

Estou com mesmo problema a tempos em 3 empresas servidores distintos e a TOTVS já pediu mil e um logs para tentar identificar e não conseguem resolver

como se isto fosse uma novidade

sei que o problema é no financeiro

Em duas empresas por causa do transtorno criei um schedule com uma rotina que gera um movimento bancário de centavos no inicio do dia antes da empresa abrir.

Parece loucura mas foi a única coisa que consegui para parar de dar problema

Levando em conta que este erro da pq as empresas desligam o Servidor diariamente
Se deixar o servidor ligado o tempo todo este erro não ocorre

Como se ele recriasse índice no primeiro movimento do dia.
Este erro começou como sempre depois de uma atualização

Tenho Protheus desde 1997

E como sempre me pergunto se tem analista realmente na TOTVS


Leonardo Luiz

Foto
Mensagem do Enviar e-mail Abrir o Perfil do usuário FTACI FTACI em 13/03/2019, 09:27 h
Local: AL  Registro: 30/08/2005  Postagens: 99
Leonardo Luiz /Silvio Coelho.

Agradeço o retorno!

Também abrir um chamado para solucionar isso, mas não resolveram nada até agora.


Vou ficar na tentativa, caso haja alguma novidade irei informar a vocês.


Taciana Oliveira



Foto
Mensagem do Enviar e-mail Abrir o Perfil do usuário JONATASSIS JONATASSIS em 14/03/2019, 14:29 h
Local: SC  Registro: 11/06/2014  Postagens: 2
Olá Pessoal,

encontrei um problema parecido aqui em minha empresa após uma atualização,
o problema foi resolvido, com um pacote de correção que eu tentei localizar aqui, e infelizmente não encontrei. Porém eu fiz um processo paliativo até o pacote ser enviando.

Causa:
Toda vêz que o LicenseServer é reiniciado, ele perde a sequencia da ultima nota, então ele refaz o controle de numeração dele!


pra ter certeza que está acontecendo o mesmo com vocês oriento a seguinte forma;

Solução:

abrir o SQL modo MASTER e rodar o query:
SELECT * FROM SYS.SYSPROCESSES WHERE BLOCKED <> 0

nela vai aparecer os processos que estão bloqueado e consequentemente o select que retornar a numeração para o License,

Após isso anotar o "numero do bloqueio" abrir o Monitor de Atividade do SQL e pesquisar o "numero do bloqueio" na coluna ID da Sessão, clicar com botaão direito em cima do processo e opção (Rastrear Processo no SQL Server Profiler) assim vai encontrar a tabela que está rodando o select ,

Como paliativo nos deletamos os registros dessa tabela deixando apenas o ultimo numero da nota antes de iniciar os serviços do protheus agilizando assim o serviço de transmissão.


OBS: conforme eu salientei o mais fácil realmente é o pacote de correção"
Como eu não lembro o pacote que usei na minha empresa eu deixo aqui o meu registro de ajuda,


caso queira me contatar eu posso auxiliar nesse processo de identificação do problema

Att

Jonatas Assis
jonatassis@hotmail.com
fone 49 9 99983886

Foto
Mensagem do Enviar e-mail Abrir o Perfil do usuário FTACI FTACI em 16/03/2019, 08:24 h
Local: AL  Registro: 30/08/2005  Postagens: 99
Jonatas e a todos, quero agradecer pelo apoio:

Fiz todas as dicas e consegui ver o erro!


Fiz o rastreamento no monitor do dbaccess, quando mandei finalizar a primeira venda e vi que a tabela FJV010 estava sendo consultada repetidamente com todos os registros nela. por isso da demora de 40m a 1 hora para finalizar a venda.
Quando eu limpei a tabela SJV010, NÃO demorou 1 minuto.
Vou solicitar a Totvs a correção.

Obrigada!!



Para postar no Fórum você precisa efetuar o seu login ou se registrar

 Mudar para Fórum

 

 

 
 
   
Pagina Principal Shopping PROTHEUS Tire suas duvidas Vagas Microsiga em todo Brasil Aprofunde seus conhecimentos Noticias Online Fale Conosco Pagina Principal