PERGUNTAS E RESPOSTAS
 
Bem Vindo, Visitante  Todos os Fórums
  ADVPL
Enviar para a impressoraImprimir  Enviar e-mail para um amigoEnviar Para um Amigo
Precisa estar Logado

Subject Assunto:
erro w0003 ao compilar fontes release 12.1.017
Versão:
12
Plataforma:
Microsoft
Complemento:
DB:
Oracle
Complemento:
LinkedIn
Foto
Mensagem do Enviar e-mail Abrir o Perfil do usuário ROBERTOMEN ROBERTOMEN em 13/09/2017, 08:44 h
Local: PR  Registro: 04/07/2017  Postagens: 46
Bom dia.

Estou atualizando o release da versão 12 para o 12.1.017

Baixei o RPO apliquei a ultima LIB apliquei o UPDISTR,,tudo ok !!!

Mas ao compilar as customizações,,todos os fontes que utilizam variável Local da erro de warning w0003

warning W0003 Local variable XXXXXXXXX never used

se eu compilo no release antigo 12.1.007,,não da o erro

Alguém já passou por este problema?

Obrigado.


Roberto

Foto
Mensagem do Enviar e-mail Abrir o Perfil do usuário CRISTIAM CRISTIAM em 13/09/2017, 10:49 h
Local: SP  Registro: 10/05/2012  Postagens: 105
Não esquenta a cabeça... isso é só um Aviso (warning).

O compilador é meio fraquinho, mas ele tenta informar que a variável nunca será usada.

Também não entende as variáveis públicas e privates do protheus.

então se for Warning, pode ignorar.


bom divertimento

abraço

Cristiam

Foto
Mensagem do Enviar e-mail Abrir o Perfil do usuário ROBERTOMEN ROBERTOMEN em 14/09/2017, 14:01 h
Local: PR  Registro: 04/07/2017  Postagens: 46
Sim Cristiam,,,é só um aviso,,compila normal.
O problema é que fica dando este aviso em todos os fontes,,mesmo que eu declare a variável e a use,,exemplo
Local ctipo :=" "
ctipo := "PA"

Quando compilo ele da o warning dizendo que ctipo nunca foi usada.

como não,,,se usei logo abaixo.

No release 12.1.007 isto não acontece.

Att,

Roberto

Foto
Mensagem do Enviar e-mail Abrir o Perfil do usuário JOAOCOELHO JOAOCOELHO em 14/09/2017, 16:51 h
Local: SP  Registro: 12/12/2013  Postagens: 71
O TDS 11.3 que fica dando essas mensagens de warning, a Totvs disse em chamado que ainda está instavel o TDS.

Foto
Mensagem do Enviar e-mail Abrir o Perfil do usuário ROBERTOMEN ROBERTOMEN em 18/09/2017, 10:08 h
Local: PR  Registro: 04/07/2017  Postagens: 46

o meu é 11.2 é problema no RPO do release 12.1.017 no rpo do 12.1.007 não da mensagens

Para postar no Fórum você precisa efetuar o seu login ou se registrar

 Mudar para Fórum

 

 

 
 
   
Pagina Principal Shopping PROTHEUS Tire suas duvidas Vagas Microsiga em todo Brasil Aprofunde seus conhecimentos Noticias Online Fale Conosco Pagina Principal